
How to use the Many Paths software 
 

What is the Many Paths software? 
Many Paths is a Java application written for Advancing Physics by Slavomir Tuleja. 

It is intended for use with Chapter 7, „Quantum Behaviour‟, of the Advancing Physics 

AS Student book. 

The software allows you to create patterns of paths for photons or electrons leaving a 

Source and arriving at a Detector. A path from Source to Detector is defined by 

creating a „waypoint‟ between them. The path is drawn in as soon as the waypoint is 

created. 

Each path has a quantum arrow. This appears in the right hand pane when the path is 

created, and changes if the path is changed. The quantum arrows for all the paths add 

up, tip to tail, to a resultant arrow. You can vary the paths and see the effects on the 

path arrows and on the resultant. 

You can save any set of paths you have created (a „scenario‟) for later use. 

These notes suggest a sequence of demonstrations which introduce the concepts 

behind the software, and show some of the quantum ideas it can illustrate. 

 

Starting up 
To start the software, double click on the application icon ManyPaths.  

DO NOT try to open the software by double-clicking on a saved Scenario. This does 

not work with this type of Java application. Open scenarios from within the 

application (File menu). 

When ManyPaths opens, you get a screen like this: 

<INSERT HERE 1FirstScreen> 

 
 

The screen shows a source and a detector, with no paths yet defined between them, so 

no quantum arrows. 



Instructions for creating paths, moving Source or Detector, altering paths, and 

selecting paths or quantum arrows are at the bottom of the screen, You can also zoom 

in or out on the screen, or drag the visible part of the screen. The instructions are 

summarised in the Help Menu.  

 

Options menu 

The Options menu lets you choose: 

 Particles to use: red photons; blue photons, low energy electrons, higher 

energy electrons. In the screen above, red photons have been selected. 

 Grid: either positions of Source, Detector and waypoints will snap to the grid, 

or this feature is turned off, allowing finer adjustment of their positions. 

 Path arrows: either, for simplicity, the amplitude of all path arrows is 

constant or, more correctly, the amplitude of a path arrow decreases with 

length of path. 

 

Finding out how ManyPaths works 
Path length and arrow rotations 

Click on the screen midway between Source and Detector. A path appears through a 

waypoint created where you clicked. The quantum arrow for this single straight path 

appears on the right hand side of the screen. (Alternatively, open the Scenario 

„OnePath&Arrow‟.) 

<INSERT HERE 2OnePath> 

 
 

Notice that the arrow points along the x-axis, with angle 0° between the arrow and the 

x-axis. The data for the path show that the arrow has made 10 complete rotations for 

this path length. Thus it also started at the source pointing along the x-axis. 

 

Now use the Options>Grid menu to turn off the feature Snap to grid. Click on the 

detector, and use the right arrow key on your keyboard to move the detector to the 

right, making the path longer. (You can also drag the detector if you prefer.) The 

arrow rotates anticlockwise as the path lengthens. This means that the phase angle for 

the arrow, measured from the x-axis, is increasing. 



With the feature Snap to grid turned on, the arrow rotates 90° for each grid square of 

path. 

<INSERT 3OnePathLonger> 

 
 

If you move the detector to the left, shortening the path, the arrow rotates clockwise, 

having made fewer rotations. 

<INSERT 4OnePathShorter> 

 
 

With a straight path like this, from Source to Detector, the position of the waypoint 

along the path does not affect the quantum arrow. Click on the waypoint and use 

arrow keys to move it to the left or right: the arrow is unchanged, because the path 

length is unchanged. 

<INSERT 5OnePathWPmoved> 



 
 

Finally, use the menu Options>Path arrows to turn on the feature Magnitude of path 

arrow decreases with increasing path length. Then move both the waypoint and the 

Detector a long way to the left, towards the Source. You will see the path arrow grow 

longer, and also change phase.  

This behaviour is necessary if the quantum particles are to obey an inverse square law 

of intensity. If the quantum amplitude is proportional to 1/distance then the 

probability of arrival will be proportional to 1/distance squared.  

<INSERT 6OnePathVshort> 

 
 

Combining arrows for paths 
The “Many paths” story of quantum behaviour says that the quantum arrow for 

particles going from source to detector is the resultant of the arrows for all possible 

paths. In this software, alternative paths are created by clicking on alternative 

waypoints between Source and Detector, making bent paths each with one kink. 



A bent path is longer than a straight one. Go back to a long straight path between 

Source and Detector, with a waypoint midway between them.  Make the path bend a 

little, by clicking on the waypoint and moving it vertically with the arrow keys. 

Watch the quantum arrow rotate anticlockwise as the path lengthens.  

<INSERT 7OnePathBent> 

 
 

Now add a second path, with a waypoint on the straight line from Source to Detector. 

The two paths both contribute to the final resultant arrow. 

With more than one path, you can always click on a path to highlight it, and see its 

quantum arrow highlighted. Or you can click in the middle of an arrow to highlight it 

and its path. 

<INSERT 8TwoPathsAdd> 

 
 



Experiment with this scenario, varying the positions of the two waypoints. See the 

arrows for the two paths always combining to give a resultant. The magnitude of the 

resultant depends on the relative phases of the quantum arrows for the two paths. 

 

Simple two-slit scenario 

Create a pair of paths passing through waypoints equally spaced on either side of the 

straight line from Source to Detector, as a crude model of a two-slit experiment. 

(Alternatively, open the Scenario „TwoSlitsSimple‟.) 

<INSERT 9TwoSlitsA> 

 
 

Notice that because the two paths are equal in length, the two quantum arrows have 

the same phase, and add to a large resultant. 

Now click on the Detector and drag it or use the arrow keys to move it vertically. The 

lower path gets longer and the upper path gets shorter. The two quantum arrows for 

the paths now differ in phase, and the resultant amplitude is decreased. 

<INSERT 10TwoSlitsB> 



 
 

Move the Detector further and you can get the two arrows with opposite phase, giving 

a nearly zero resultant. 

<INSERT 11TwoSlitsC> 

 
 

By moving the detector vertically up and down, you can explore the two-slit 

interference pattern. Where the resultant is near zero you will find, by clicking on the 

two waypoints in turn, that the information panel shows one arrow to have made half 

a rotation more than the other. 

You can change photon frequency and wavelength in Menu Options>Particles. For 

blue photons, the phase of path arrows changes more rapidly as the detector is moved.  

 

More interesting scenarios 
Now look at the range of more interesting scenarios that can be explored. They 

include a more realistic two-slit scenario, diffraction by a single slit, reflection by a 



plane mirror, the reason for straight line propagation, and focusing by a curved 

mirror. 

More realistic two-slit experiment 

Open the scenario „TwoSlitsWider‟. This illustrates the fact that in any real situation, 

a possible physical path is always a bundle of closely spaced photon paths.  

<INSERT 12TwoSlitsWider> 

 
 

The arrows for the various paths from Source to Detector can no longer all be in 

phase, even though the slits are equally spaced either side of the central line from 

Source to Detector. Move the Detector vertically to show that the two-slit interference 

pattern still appears, with places where the resultant arrow is near zero. 

 

Diffraction at a single slit 

Open the scenario „Single slit‟. You see a bundle of closely spaced paths going 

through a narrow hole. The quantum arrows for the paths nearly, but not quite, line 

up. 

<INSERT 13SingleSlitA> 



 
 

Move the detector, and you find a place where the arrows give a small resultant. 

<INSERT 14SingleSlitB> 

 
 

Reflection at a plane mirror 

Open the scenario „PlaneMirror‟. You see paths travelling via many waypoints on the 

surface of a plane mirror. Click on the button Notes to see an explanation. 

 

<INSERT 15PlaneMirrorA> 



 
 

Notice how the major part of the amplitude of the resultant is contributed by paths, 

highlighted in red, which go near the centre of the mirror, close to where the law of 

reflection is obeyed. Paths far from the centre curl up rather than line up, contributing 

little to the final total amplitude. This is how quantum physics explains the law of 

reflection. Differences in paths close to the classical path are small, so their arrows do 

not differ much in phase, and the arrows line up. 

 

To confirm this, open the scenario “reflectionLaw‟. Here only the paths close to the 

classical reflected path are shown. You can see that they differ little in phase, and so 

line up to give a large resultant.  

<INSERT 16PlaneMirrorB> 

 
 

Reflection by a curved mirror 

Open the scenario „Elliptic-mirror‟. Click on the button Notes to see an explanation. 



<INSERT EllipticMirror> 

 
 

This scenario is a tour-de-force of drawing by Slavomir Tuleja. You recall that for an 

ellipse, the sum of distances to the surface from the two foci is constant. Thus paths 

from a Source placed at one focus to a Detector placed at the other focus, are all equal 

in length. Their quantum arrows are all in phase, and all add to a very large resultant. 

Move the Detector a little way from the focus to see just how sharp the focusing is. 

Try deforming the ellipse a little (move a few waypoints slightly) to see why a 

telescope mirror has to be polished to a very fine tolerance. 

 

Straight line propagation 

Open the scenario „linearProp‟. Click on the button Notes to see an explanation. 

<INSERT 18LinearPropA> 

 
 



Many paths from Source to Detector are shown. They go by routes far from the 

classical straight line path. However, it is only the bundle of paths close to the 

classical straight line path whose arrows contribute much to the total resultant 

amplitude. These paths differ little in length, so their quantum arrows vary little in 

phase and the arrows line up. By contrast, paths far from the classical straight line 

path vary greatly in length, their quantum arrows vary greatly in phase, and these 

arrows curl up. They contribute little to the total resultant amplitude.  

<INSERT 19LinearPropB> 

 
Move the Detector vertically, to see that it is always the arrows for paths close to the 

straight line from Source to Detector that contribute most to the resultant arrow. 

 

Summing up 
Everything here follows from one simple principle of quantum behaviour: 

To find the probability of a photon (or electron) going from A to B you have to 

consider every possible path it might take from A to B. For each path there is a 

quantum arrow, with magnitude and phase. The arrows rotate more the longer the 

path. Find the resultant arrow, obtained by adding the arrows for all possible path, tip 

to tail. The probability of arrival at A is proportional to the square of the amplitude of 

this resultant arrow. 

That‟s it. That‟s quantum behaviour. The ManyPaths software lets you visualise the 

principle in action. 

 



Mouse, Keyboard and Menu commands 
In ManyPaths, the screen is divided into two panels: 

 Left panel: the Scene, with Source, Detector and paths between them 

 Right panel: the Arrows, where arrows from all chosen paths are shown, and 

added tip to tail to get their resultant. 

When the cursor hovers over one panel, that panel is activated, shown by a darker 

border round it. The mouse and keyboard interactions for the active panel are shown 

at the bottom of the screen.  

 

Menu actions 

Most menu actions have keyboard shortcuts, shown in brackets below. 

 File menu:  

o New starts a new empty scenario [CTRL N] 

o Open opens a saved .sce scenario file [CTRL O] 

o Save saves the current scenario to a .sce file [CTRL S] 

o Quit quits ManyPaths [CTRL Q] 

 Edit menu 

o Undo undoes last action taken [CTRL Z] 

o Redo restores last action undone [CTRL Y] 

o Delete selected waypoints deletes all currently selected waypoints 

[also Backspace or Delete key, or CTRL D] 

o Delete all waypoints does just what it says 

 Options menu 

o Source: select between red or blue photons, or low or higher energy 

electrons 

o Grid: toggles between active or inactive Snap to grid  

o Path arrows: toggles between active or inactive Magnitude of path 

arrow decreases with increasing path length 

 Help menu [CTRL H] provides a brief reminder of keyboard actions 

 

Scene (left panel) actions 

 

Action Mouse or keyboard 

Create a path: Click at a point on the screen, creating a waypoint 

through which a path is drawn from Source to 

Detector 

Create a set of paths Click at a point on the screen and then drag. A 

sequence of equally spaced waypoints is created. 

Select a path Click on the waypoint of the path. Its arrow is also 

selected 

Select a set of paths Shift-click on waypoints of the paths. Shift-click 

on a pair of waypoints to select all waypoints 

between them. The arrows are also selected 

Deselect or reselect a path Control-click on the waypoint to toggle selection 

on or off. 

Delete a path or set of 

paths 

Select the path or paths and press Backspace or 

Delete key or CTR D. 

Move a waypoint or set of 

waypoints 

Select the waypoint or set of waypoints, and drag 

or use arrow keys. 



Move Source or Detector Select Source or Detector, and drag it or use arrow 

keys 

Move the viewing area of 

the screen 

Shift-drag at an empty part of the screen 

 

Arrow (right panel) actions 

 

Action Mouse or keyboard 

Select an arrow Click on the middle of the arrow: its path is also 

selected. 

Select a set of arrows Shift-click on the arrows. Shift-click on a pair of 

arrows to select all arrows between them. The 

paths care also selected 

Deselect or reselect an 

arrow 

Control-click on the arrow to toggle selection on 

or off. 

Delete an arrow or set of 

arrows 

Select the arrow or arrows and press Backspace or 

Delete key or CTR D. The paths are also deleted. 

Move the viewing area of 

the screen 

Shift-drag at an empty part of the screen 

Zoom in or out Turn mouse wheel up to zoom in and down to 

zoom out. 

 

 

 

 


